Login unavailable
Incident Report for BlockEx Ltd.
Resolved
Logging in is operational again.
Posted 5 months ago. Sep 07, 2018 - 16:49 BST
Investigating
At the moment, we're investigating a problem with logging in into Blockexmarkets.
Posted 5 months ago. Sep 07, 2018 - 16:46 BST
This incident affected: BlockExMarkets Website and BlockExMarkets Web API.